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MS Excel



Lesson Objectives

At the end of this lesson, you would be able to:

• Identify fundamental elements and data types 
of a spreadsheet

• Create, navigate, and manage worksheets

• Enter and edit cell data 

• Address and reference cells

• Work with formulas and functions

• Create charts
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Familiarization with the Excel 

Workspace

• Spreadsheets are displayed in a grid layout. 

• Column headings = letters

– To highlight an entire Column, click on any of the 
letters. 

• Numbers = rows 

– The exact number of rows and columns are 
1,048,576 rows and 16,384 columns.

• A Cell is a letter combined with a number. So 
if you combine the B column with Row 5, you 
get Cell B5.
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Microsoft Excel’s Opening Screen
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Parts of the Excel Screen That 

You Need to Know

S/N Name Description

1. Collapse the

Ribbon button

Click this button to hide the Ribbon temporarily. 

Double-click any Ribbon tab to make the Ribbon 

remain visible. Ctrl+F1 is the shortcut key that

does the same task.

2. Column letters Letters range from A to XFD—one for each of 

the 16,384 columns in the worksheet. You can 

click a column heading to select an entire 

column or click between the columns to change 

the column width.

3. File button Click this button to open Backstage view, which 

contains many options for working with your 

document (including printing) and setting Excel 

options.
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Parts of the Excel Screen That 

You Need to Know Cont’s

S/N Name Description

3. Formula bar When you enter information or formulas into a 

cell, it appears in this bar.

4. Horizontal

scrollbar

Use this tool to scroll the sheet horizontally.

5. Macro recorder

indicator

Click to start recording a Visual Basic for 

Applications (VBA) macro. The

icon changes while your actions are being 

recorded. Click again to stop

recording.

6. Name box This box displays the active cell address or the 

name of the selected cell,

range, or object.
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Parts of the Excel Screen That 

You Need to Know Cont’s

S/N Name Description

7. New Sheet

button

Add a new worksheet by clicking the New Sheet 

button (which is displayed after the last sheet 

tab).

8. Page View

buttons

Click these buttons to change the way the 

worksheet is displayed..

9. Quick Access

toolbar

This customizable toolbar holds commonly used 

commands. The Quick

Access toolbar is always visible, regardless of 

which tab is selected.

10. Ribbon This is the main location for Excel commands. 

Clicking an item in the tab

list changes the Ribbon that is displayed.
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Parts of the Excel Screen That 

You Need to Know Cont’s

S/N Name Description

11. Ribbon Display

Options

A drop-down control that offers three options 

related to displaying the Ribbon.

12. Row numbers Numbers range from 1 to 1,048,576—one for 

each row in the worksheet. You can click a row 

number to select an entire row or click between 

the row numbers to change the row height.

13. Search The Search control is a magnifying glass with 

the caption “Tell me what you want to do.” Use 

this control to identify commands or have Excel 

issue a command automatically.

14. Selected cell

indicator

This dark outline indicates the currently selected 

cell or range of cells. (There are 17,179,869,184 

cells on each worksheet.)
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Workbooks and Worksheets

• Workbook: A workbook is another word for 

your Excel file. Excel automatically creates a 

blank workbook when you open it.

• A worksheet is a collection of cells where 

you keep and manipulate the data. By 

default, each Excel workbook contains 

three worksheets.

– When you open Excel, Excel automatically 

selects Sheet1 for you. The name of the 

worksheet appears on its sheet tab at the bottom 

of the document window.
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Managing Worksheets

• Rename a Worksheet
– By default, the worksheets are named Sheet1,

Sheet2 and Sheet3. To give a worksheet a more
specific name, execute the following steps.

– 1. Right click on the sheet tab of Sheet1.

– 2. Choose Rename.

• Insert

• Move

• Rename

• Delete
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How to Enter Text and Numbers 

in a Cell

• To make a start, we'll create 
this simple spreadsheet:

– Type the word: Numbers

– Hit the Enter key on your 
keyboard

– The active cell will move down 
one, to cell A2

– Type the number 3, and again 
hit the Enter key on your 
keyboard

12



Types of data
• In each cell there may be the following data 

types:

– Labels -- (text with no numerical value) 

– Number data (constant values)

– Formulas (mathematical equation used to 
calculate) 

Data Types Examples Descriptions

LABEL
Name or Wage or 

Days

anything that is just 

text

CONSTANT 5 or 3.75 or -7.4 any number

FORMULA =5+3 or = 8*5+3 math equation
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Types of Data cont’s

• Apply a number format

– To distinguish between different types of 

numbers, add a format, like currency, 

percentages, or dates.

– Select the cells that have numbers you want 

to format.

– Click the Home tab, and then click the arrow 

in the General box.

– Pick a number format.
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Auto complete, Auto fill and Auto 

correct
• When you can see the AutoFill cursor, hold down your

left mouse button and drag to the right

• Drag your mouse all the way to cell H3, as in the

following image:

• When your cursor is in the H3 cell, let go of the left

mouse button

• Excel will now complete the days of the week:
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• On the Home tab, in the Alignment group,

center the number.
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Text editing
• On the Home tab, in the Font group, 

change the Font color.
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Formatting
• Cell merging: Home - Alignment - Merge 

and Center

• Orientation - Alignment

• Top Align
• Align Text Left
• Orientation then select the rotation

option that you want.
• To wrap the text in a cell, click Wrap Text.
• To justify the text in a cell, on

the Alignment tab, click the drop-down 
box under Horizontal, and then 
click Justify.
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Column and Row fitting

• Home - Cells group, click Format

• Cell Size, click AutoFit Column

Width

• Select the row or rows that you

want to change.

• On the Home tab, in

the Cells group, click Format.

• Under Cell Size, click AutoFit Row

Height.
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Freeze, hide and split columns/rows 

(the Window menu)

• Freeze Top Row: View - Freeze Panes, Freeze Top

Row.

• Split
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Insert, Delete Rows, Columns

• Home- Cells - Insert, - Insert Sheet Rows.

• Home - Cells - Delete:

– Delete Cells.

– Delete Sheet Rows.

• If you are deleting a cell or a range of cells, in 

the Delete dialog box, click Shift cells left, Shift 

cells up, Entire row, or Entire column.

• If you are deleting rows or columns, other rows 

or columns automatically shift up or to the left.
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Basic Formulas

• Formulas are math equations that 
CALCULATE a value to be displayed. 

• You must have an equals sign ( = ) as the 
first character in a cell that contains a 
formula.

• The = sign tells excel that the contents of the 
cell is a formula

• Without the = sign, the formula will not 
calculate anything. It will simply display the 
text of the formula.

22



Order of Operations

• Excel applies the rules of mathematics to determine 
how formulas are calculated. The following is the 
order in which arithmetic operators are applied:

1. Negative number (−)

2. Percent (%)

3. Exponentiation (ˆ)

4. Multiplication (*) and division (/) (left to right)

5. Addition (+) and subtraction (−) (left to right)

• For example, consider the original formula:

7 + 8 * 3 / 2 − 4 = 15
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Explicit values and cell references

You can use both explicit values and cell 

references in a formula:

– Formula with only cell references: =a1*b1

– Formula with only literal values: =100/27

– Formula with both cell references and literal values:

=a1/100



Relative, Absolute and Mixed 

References
• By default, all cell references are relative 

references. 

• When copied across multiple cells, they change 
based on the relative position of rows and 
columns. 
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Relative, Absolute and Mixed 

References

• Relative references are especially 

convenient whenever you need 

to repeat the same calculation across 

multiple rows or columns.
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Relative, Absolute and Mixed 

References

• Sometimes you do not want a cell reference 

to change when you move or copy it. To 

make an absolute cell reference, use the 

dollar sign ($) before the column and row of 

the cell you want to reference.
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Relative, Absolute and Mixed 

References
• absolute cell reference

28



Relative, Absolute and Mixed 

References

• You can also create a mixed reference in 

which a column or a row is absolute, and 

the other is relative. 

• For example, if the cell reference in a 

formula is $A5 or A$5, you would have a 

mixed reference in which one component is 

absolute and one is relative.
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Functions

• A formula is an expression which calculates 
the value of a cell.

• Functions are predefined formulas and are 
already available in Excel.

• Most often used functions:

• SUM

• AVERAGE

• COUNT

• MAX, MIN
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Entering a Function 1

• Next to the formula 

bar, you'll see an FX 

button. This is the 
Formula Wizard: 

• When you click the 

FX button, you'll see 

the Insert 

Function dialogue 
box appear:
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Entering a Function 2

• The second way to enter a Function in Excel is 
through the panels on the Ribbon. 

• Click inside cell B9 on your spreadsheet. This is 
where we'll place the Average for the cells A1 to A8.

• Click the Formulas menu at the top of Excel
• Locate the Function Library panel. 
• As you can see, in Excel functions are split into 

categories. The Average function is in a few places. 
The easiest way to use Average is with AutoSum. 
Click the down arrow on AutoSum to see the 
following:
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AVERAGE
When you click the 
FX button, you'll see 
the Insert 
Function dialogue 
box appear:
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MAX, MIN

• These functions (max and min) return the 

maximum and minimum number from an 

array/table
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TRUE, FALSE, IF function
• The IF function allows you to make logical comparisons 

between a value and what you expect. 

• IF(Something is True, then do something, otherwise do 
something else)

• So an IF statement can have two results. The first 
result is if your comparison is True, the second if your 
comparison is False.

• TRUE and FLASE is automatically calculated by Excel:

• =A1=B1 - if the cells contain the same value TRUE, -
if the cells contain different value FALSE
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Using Count IF function
• The COUNTIFS function counts the number of

cells within a range that meet multiple criteria. The
syntax is COUNTIFS(Criteria_range1, Criteria1,
Criteria_range2, Criteria2, …).

• You can create up to 127 ranges and criteria.
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Using Count IF function cont’s
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VLOOKUP & HLOOKUP
• The “V” in VLOOKUP stands for vertical. 

This formula is used when the comparison 
value is in the first column of a table.

• Excel goes down the first column until a 
match is found and then looks in one of the 
columns to the right to find the value in the 
same row. 

• The VLOOKUP function syntax is 
LOOKUP(Lookup_value, Table_array, 
Col_index_num, Range_lookup).
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Using VLOOKUP
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VLOOKUP & HLOOKUP cont’s

• The “H” in HLOOKUP stands for horizontal. 
HLOOKUP searches horizontally for a 
value in the top row of a table or an array 
and then returns a value in the same 
column from a row you specify in the table 
or array. 

• Use HLOOKUP when the comparison 
values are located in a row across the top 
of a table of data and you want to look in a 
specified row
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Using HLOOKUP
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Creating Charts

• A chart is a graphical representation of numeric
data in a worksheet. Data values are represented
by graphs with combinations of lines, vertical or
horizontal rectangles (columns and bars), points,
and other shapes.

• The Insert tab contains the command groups you’ll
use to create charts in Excel
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Creating Charts
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Creating Charts
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Sources
 Bucki, L. A. (2013). Microsoft® Word® 2013

Bible, John Wiley & Sons: Inc. Indianapolis, IN
 Michael Alexander, M. & Kusleika, D. (2019).

Excel® 2019 BIBLE, John Wiley & Sons Inc.:
Indianapolis, IN

• Free Computer Tutorials: 
http://www.homeandlearn.co.uk/excel2007/Exce
l2007.html

• Excel Easy#1 Excel tutorial on the net
• http://www.excel-easy.com/basics.html
• Microsoft Official Page: 

https://support.office.com/
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